WordPress 5.5 Update

Share on facebook
Share on twitter
Share on linkedin

EDIT: It is now safe to update to 5.5.x

You’re probably wanting to click that shiny update button and push your WordPress version to 5.5. Well DON’T. Take your finger off your mouse and read this first.

First off, you should NEVER update to a release like 5.X. You should wait until 5.5.X to update at a MINIMUM!!

If you choose to update your site because you can’t help yourself, be sure to do it on a staging site first. Most hosting companies provide this in your hosting package. Otherwise, perform a backup of your site, update and check for changes you don’t like then restore if needed.

That’s it. Simple and easy. Just don’t update. Wait for the WilCity developers to catch up on the WordPress version.

Leave a Reply

Your email address will not be published. Required fields are marked *

WilCity Guide Bug Report